
Quick Start Guide To ExpressPCB

There are two parts to ExpressPCB, our CAD software and our board 

manufacturing service.  Our CAD software includes ExpressSCH for drawing 

schematics and ExpressPCB for designing circuit boards.  We also provide a low 

cost, high quality and fast source for having your boards made.  Here is how it 

works:

This document
is formatted for
easy printing.

1. We recommend that you begin by drawing a schematic using ExpressSCH.  

2. Next, use the ExpressPCB program to lay out your PC board.  If you link your schematic 

to ExpressPCB, it will guide you through the wiring process.

3. When your layout is complete, determine the exact cost to have boards made with the 

Compute Board Cost command.

4. To order the boards, enter your name, address and billing information into ExpressPCB 

and press the Send button within the Order Boards Via The Internet dialog box.

5. In a few business days (typically 2 or 3) an overnight courier will deliver your PC boards.

Designing a PCB

ExpressPCB is a very easy to use 

Windows application for laying out 

printed circuit boards.  

While not required, we suggest that 

you draw a schematic for your circuit 

using the ExpressSCH program.  By 

linking your schematic, ExpressPCB 

will guide you by highlighting the pins 

that should be connected together 

with traces.

Note:  ExpressPCB defaults to 

coordinates in inches.  The exact 

position of the mouse is displayed on 

the status line.  

The Side Toolbar

The toolbar along the left side of the ExpressPCB main window is used to select the editing modes, 

such as place component and place trace.  These are the side toolbar buttons:

Select, drag or set properties of an 

item in the layout.
Place text in the layout.

Zoom to view a selected area. Place a rectangle.

Place a pad (either a through hole 

or surface mount pad).
Place a circle or an arc.

Place a component. Place a filled power or ground plane.

Place a trace.
Insert an edge segment in the board 

perimeter.



Insert a corner into a trace. Display information about a pad.

Disconnect a trace. Highlight net connections.

At the bottom of the side toolbar are 4 additional buttons that toggle on and off features of the 

display:

Toggle display of silkscreen layer. Toggle display of bottom copper layer.

Toggle display of top copper layer. Toggle Snap-to-grid.

The Top Toolbar

When you click on a side toolbar button, additional buttons are added to the top toolbar, specific to 

the function selected.  These buttons are always displayed on top:

Open a schematic file. Zoom in. Zoom to previous size.

Save schematic file. Zoom out. Display Options dialog box.

Undo last operation. Zoom to see all. Display the Component 

Manager.

These buttons are added on top as needed:

Move selected items to 

top layer.
Set rotation up. Highlight first net.

Move selected items to 

bottom layer.
Set rotation left. Highlight previous net.

Select top silkscreen 

layer.
Set rotation down. Highlight next net.

Select top copper layer. Set rotation right. Highlight last net.

Select bottom copper 

layer.

Set text weight to 

normal.
Set text weight to bold.

Beginning a New Layout

1. Begin a new layout by running ExpressPCB.  If you are designing a four-layer board, select 

Board properties from the Layout menu and check the 4-Layer option.  

2. In the main window, the yellow rectangle defines the perimeter of the PC board.  Set the size 

of your board by moving three of its four corners (the upper left corner is fixed at 0,0).  Move 

the corners by dragging them with the mouse, or by double-clicking them and entering 

coordinates.  Additional corners can be added to the perimeter to change its shape (see 

ExpressPCB:  Changing the Board Perimeter).

3. Select the size of the Default via.  In some cases as you place traces, ExpressPCB inserts via 

(plated-through holes) when a trace changes between the upper and lower layers.  When 

inserted, these via pads are always visible.  Set the Default via in the Board properties dialog 

box.

4. If you have drawn a schematic of your circuit using ExpressSCH, link the schematic file to your 

circuit board layout using the Link schematic to PCB command found under the File menu.

5. Finally, give your board a name by selecting Save As from the File menu.

Zooming and Panning

The easiest way to move around your layout is with the scroll wheel on the mouse.  Turning the 

wheel zooms in and out.  Pressing the wheel and dragging the mouse pans.



The Grid

The Snap-to-grid is an invisible grid that helps you align traces and components.  With the 

Snap-to-grid on, you will notice that as you place objects, they gravitate to a grid boundary.  The 

Snap-to-grid spacing is set from the Options dialog box or from the Snap listbox located on the 

lower statusbar.  To toggle the Snap-to-grid on or off, press the G key or click .

Placing Components

The easiest way to place components 

in your board layout is to use the 

Component Manager.  

Tip:  Use the Find button to search for 

a PCB footprint by its name.

To place a component:

1.   Click the  button located on 

the top toolbar to display the 

Component Manager.

2. Select one of these categories:

•  Library components  -  Components that are included with the program

•  Custom components  -  Components that you have drawn

•  Favorite components  -  Components or symbols that you have book-marked

3. From the list box, choose the item to insert then select the component's 

orientation (rotated up, left, down, or right) by clicking one of these 

buttons:

4. Press the Insert component into PCB  button, then drag the component to the desired location.

5. Assign the component's Part ID (such as R1 or U2).  To do this, select  then double-click 

on the component to display its Component properties dialog box.

Note:  Setting the Part ID is required if you link your schematic and PCB.  In 

order to mate a schematic component with one on the board layout, the Part IDs 

must match. 

Placing Pads

Individual pads are used both to build new components and as via.  To insert a pad:

1. From the side toolbar, select  or press the P shortcut key.

2. Select a pad size from the drop down list box on the top toolbar.  There are several pad types: 

round, square, surface mount and via.  Vias are used to pass traces between layers.  Regular 

pads differ from via pads in that ExpressPCB may eliminate a via if the traces connecting to it 

are all on the same layer.

Tip:  If you cannot find a pad the size you need, a custom pad is easily created.  

See:  ExpressPCB:  Making Custom Pads

3. To place the pad, click on your layout at the desired location.



Placing Traces

These are the steps to add traces to your layout.  If you have drawn a schematic for your circuit, be 

sure to read the section Linking the Schematic and PCB before you begin.

  1. From the side toolbar, select  or press the T shortcut key.

2. Select the trace width from the drop down list box on the top toolbar:  A width of 0.010" is a 

good default for digital and analog signals.  For power lines, use traces 0.05" or wider.

3. Select the layer by clicking  or by pressing the L shortcut key.

4. Move the mouse to the trace's first end point and click.  Drag the trace to the second end 

point, then click again.  Continue placing trace segments (use the L key to change layers) 

until you have reached the final end point.

 Tip:  Keep an eye on the statusbar when connecting traces to components. It will 

display the pin and part number to which the trace is connected.

5. As you drag the trace, the L key changes layers, the Del key deletes the previous segment, 

the + and - keys zoom in and out, the G key toggles the snap-to-grid on and off.  The 

Spacebar sets the trace, and the Esc key cancels it.

6. To complete the operation, press the Spacebar or click right.

Working with Traces

Traces themselves cannot be moved.  The path of a trace is determined by 

the straight line between its two connections.  Therefore, to move a trace, you 

need to connect it to something different or to move what it is connected to.

Corners in traces allow them to bend.  They are displayed as small square 

blocks at the ends of traces.  A trace with two corners is shown here.  In your 

final PC board layout, the corners will not be included.

Corners can be dragged, inserted or deleted to change the trace's path.  To insert a corner, select 

 then click  to choose the layer on which the corner will be placed.  Next click on the 

trace at the point where you want to insert the corner.

To disconnect a trace and reconnect it elsewhere, select  from the side toolbar.  Next, click on 

the trace near the point you want to disconnect, then drag the trace to a new pin.

Placing Filled Planes

Filled Planes are used to add ground or power planes to a circuit, usually on 

double-sided boards.  They can be placed on the top or bottom layers.  The 

perimeter can have the shape of any polygon and the interior is automatically 

insulated from traces and pads.

Note:  The Filled Plane feature is not supported in Windows 95, 98 or ME.

To place a Filled Plane, select , then on the top toolbar choose the Draw filled plane option, 

along with the layer.  Next use the mouse to draw the perimeter.  Do this by clicking the left 

mouse button at each corner, then clicking right after you have placed the last corner.

Connect a pad to a plane by right clicking on the pad.  In the popup menu, select one of the Top 

layer pad shape or Bottom layer pad shape options.

Important:  After creating a plane, you will want to inspect it for possible problems.

Learn how here:  ExpressPCB: Placing Power and Ground Planes



Tip:  After adding a Filled Plane, you may want to lock or hide it using the Options 

dialog.  If planes are hidden, they still will be included when the boards are 

manufactured.

Designing a Four-Layer PCB

Begin a four-layer design by selecting the 4-Layer option in the Board properties dialog box. This 

adds two inner layers to your layout, a Power plane and a Ground plane. 

Any through-hole pad in a layout can be connected to either the Power or 

Ground internal planes by right clicking on the pad.  In the popup menu, 

select one of the Power inner layer pad or Ground inner layer pad options.

Connections to the Power plane are displayed with a + over the pad. 

Ground plane connections are marked with a - symbol.

To look at the actual inner layer planes, select View Power layer or View 

Ground layer in the Options dialog box.  This example shows pins 1, 3, and 8 

connected to the Power plane. The other pads are isolated.

You will notice that pins 1 and 8 are connected with Thermal pads, while pin 3 

is connected with a Solid pad.  Typically Thermals are used with pads 

connecting to a plane because they improve the solderability of the pad, 

reducing the chance of a "cold solder joint".

When viewing inner layers, you can draw split planes and keep out areas.

Setting Properties of an Item

All the items in your layout have properties.  For example, the properties of a pad include the pad 

type and its XY coordinates.

To view or change the properties of an item, select  then double click on the item.

Copying, Deleting and Moving Items

ExpressPCB uses standard Edit commands for Copy, Cut and Paste.  To copy an item or several 

items, first select them.  From the Edit menu choose Copy, then from the Edit menu choose Paste.

Deleting items from your layout is as easy as selecting them and pressing the Del key.

There are three ways most items can be moved.  Typically, items can be moved by selecting and 

dragging them.  They can also be moved with the arrow keys by selecting them and then pressing 

Ctrl-right, Ctrl-left, Ctrl-up or Ctrl-down.  Alternately, an item can be moved by changing the 

coordinates set in its properties dialog box.

Tip:  To copy a group of items from one layout file to another, select and copy the 

items of interest into the clipboard.  Load the second file into ExpressPCB and paste.  It 

is not possible to copy items between two programs running at the same time.

Changing the Layer of Items

To move traces, rectangles and text between the top and bottom copper layers, select them with 

the mouse then click  to move the selection to the top layer; click  to move it to the bottom.



Linking the Schematic and PCB

Running the traces from component to component is simplified if the schematic and PCB are 

linked.  Embedded in ExpressSCH schematic files are wiring lists (called NetLists).  When linked, the 

ExpressPCB program highlights which pins need to be wired together.

Before linking your schematic, check it for errors.  Run the command Check schematic for netlist 

errors from the File menu of ExpressSCH.  If errors are reported, correct them, then save the 

schematic file.  For more information, see:  ExpressSCH: Checking the Schematic for Errors

Next, for every part referenced in your schematic, you need to insert the component footprint for 

that part in your PCB design.  Also, the Part ID values for each footprint must be set.  To learn how 

to insert the footprints and set the IDs, see:  Placing Components

Note:  The Part IDs are used to match a schematic component with its PCB footprints 

when highlighting a net.  (i.e. a Part ID of R12 in the schematic will be matched with a 

PCB footprint that also has the Part ID set to R12).  

Now link your schematic and PCB files.  From the File menu of the ExpressPCB program, select the 

command Link schematic to PCB.

Once linked, ExpressPCB can show you which pins should 

be connected together by highlighting them in blue.

To highlight a "Net", select  from the side toolbar, 

then click on one of the pads of a component.  This 

highlights the other pads that should be wired to the pad 

you've selected.  If the schematic has nothing connected 

to that pin, then no pads are highlighted.

You can step through all of the "Nets", from first to last, to visually inspect your PCB for missing 

connections.  This is done by selecting  and then clicking on  to navigate 

through all of the nets:

Tip:  The ExpressPCB program reloads the linked schematic file every time the .PCB 

file is opened.  If you run ExpressSCH and ExpressPCB at the same time, you can 

update the link by first saving the schematic within ExpressSCH, then selecting Refresh 

link to schematic from the File menu in ExpressPCB.

Making Custom PCB Components

ExpressPCB includes many components that you can use to create your PCB.  However if you need 

a footprint not found in our library, you can easily build your own.  Here is how:

1. First add the pads by selecting  and choosing a pad type on the 

top toolbar.  Carefully position the pads with the correct spacing.  It 

may be helpful to change the Snap-to-grid spacing in the Options dialog.

Tip:  If you cannot find a pad the size you need, create a 

custom pad.  See:  ExpressPCB:  Making Custom Pads



2. Assign each pad a Pin number.  This must be done if you link your PCB 

to its schematic.  Assign pin numbers by selecting  and then 

double clicking on each pad to display its Pad Properties dialog box.  In 

the Pin number field, enter the pin number.

3. Draw the component outline for the new part on the silkscreen layer.  

Draw straight lines by selecting  or circles and arcs using .  

Be sure to select the silkscreen layer before drawing the outline by 

clicking .  The recommended line width for drawing component 

outlines is 0.012".

4. Group everything together to combine it into a single component as 

follows.  Select all of the objects in your new part by clicking  and 

then dragging the mouse to enclose them.  From the Component menu, 

choose the command Group to make PCB component.  Next, double 

click the new component to assign its Part ID (i.e. U12).

5. Save the component to add it to the Custom components list.  Do this by selecting the part 

with the mouse and then choosing Save custom component from the Component menu.

FYI:  ExpressPCB stores every component in its own file.  These files have the .P extension 

and are saved in the directories: 

•  Program Files\ExpressPCB\PCBComponents_Library

•  Program Files\ExpressPCB\PCBComponents_Custom

Modifying Library Components

Sometimes it is easiest to build a new component by starting with one from our library, for example 

to change the pad sizes.  This is done by first inserting the library component into your layout.  

Next select it with the mouse then choose the Ungroup PCB component command from the 

Component menu.  Now select only the pads and double click on one.  In the Pads Properties 

dialog, change the pad size.  Finally, group the component back together as described above to 

create the new part.  Your changes will NOT affect the original part in the ExpressPCB library.

Having PC Boards Made

When you have completed your layout, the next step is to have the boards made.  Before ordering, 

you can determine the cost using the Compute Board Cost command from the Layout menu.

To order your boards, connect your computer to the Internet then select the Order Boards Via The 

Internet command from the Layout menu.  Fill in the forms that follow and press the SEND button.  

Your order is sent to ExpressPCB for manufacturing.

For more information, see the online help section Having PC Boards Made.

How to Contact Us

Please feel free to contact us if you have questions, comments or suggestions.  We can be reached 

by email at: support@expresspcb.com
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